Как документ сохранить в xml документ с помощью средств xml сериализации

Как документ сохранить в xml документ с помощью средств xml сериализации

Нужно документ РеализацияТоваровУслуг (ссылка на который выбирается в диалоге создаваемой обработки) перенести в другую базу данных. Структура конфигураций идентична. Справочники (и другие сопутствующие объекты) синхронизированы по значениям внутренних идентификаторов.
Для выгрузки потребуется выполнить следующий фрагмент кода:

При выгрузке создаем элемент Root исходя из соображений, что в XML-документе должен быть только один корневой узел, а в общем случае (но не в нашем) выгружаться может не один объект.
Для загрузки выгруженного значения используем следующий фрагмент кода:

Отличительные черты XML

Документы в форматах HTML и XML содержат данные, заключенные в теги, но на этом сходство между двумя языками заканчивается. В формате HTML теги определяют оформление данных — расположение заголовков, начало абзаца и т. д. В формате XML теги определяют структуру и смысл данных — то, чем они являются.

При описании структуры и смысла данных становится возможным их повторное использование несколькими способами. Например, если у вас есть блок данных о продажах, каждый элемент в котором четко определен, то можно загрузить в отчет о продажах только необходимые элементы, а другие данные передать в бухгалтерскую базу данных. Иначе говоря, можно использовать одну систему для генерации данных и пометки их тегами в формате XML, а затем обрабатывать эти данные в любых других системах вне зависимости от клиентской платформы или операционной системы. Благодаря такой совместимости XML является основой одной из самых популярных технологий обмена данными.

Учитывайте при работе следующее:

HTML нельзя использовать вместо XML. Однако XML-данные можно заключать в HTML-теги и отображать на веб-страницах.

Возможности HTML ограничены предопределенным набором тегов, общим для всех пользователей.

Правила XML разрешают создавать любые теги, требуемые для описания данных и их структуры. Допустим, что вам необходимо хранить и совместно использовать сведения о домашних животных. Для этого можно создать следующий XML-код:

Как видно, по тегам XML понятно, какие данные вы просматриваете. Например, ясно, что это данные о коте, и можно легко определить его имя, возраст и т. д. Благодаря возможности создавать теги, определяющие почти любую структуру данных, язык XML является расширяемым.

Но не путайте теги в данном примере с тегами в HTML-файле. Например, если приведенный выше текст в формате XML вставить в HTML-файл и открыть его в браузере, то результаты будут выглядеть следующим образом:

Izzy Siamese 6 yes no Izz138bod Colin Wilcox

Веб-браузер проигнорирует теги XML и отобразит только данные.

Один из форматов, в которых вы можете сохранять документы Word, — это формат XML. Команды XML упрощают обмен информацией между программами, поскольку они содержат не только данные документа, но и описание их форматирования, включая способ организации в документе. Любая другая программа, поддерживающая формат XML, может работать с данными, так как она получает информацию о форматировании и организации данных из встроенных команд XML.

Чтобы сохранить документ в формате XML, выполните следующие действия:

1. Выберите в меню Файл пункт Сохранить как (Save As).

2. В диалоговом окне Сохранение файла выберите в раскрывающемся списке Тип файла (Save as Туре) пункт XML-документ (XML Document). Введите имя файла и папку, где он будет сохранен (рис. 10.20).

3. Если вы желаете отменить форматирование документа в Word и обмениваться с другими программами только базовыми данными, поставьте флажок в поле Сохранить только данные (Save Data Only).

4. Щелкните по кнопке Сохранить.

Сохранять документ в формате XML нужно только в том случае, если в вашей компании практикуется обмен информацией с другими пользователями.

Дополнительную информацию о формате XML вы найдете в книге «Истинный мир формата XML» Стива Хользнера (Steve Holzner) издательства Peachpit Press.

Как из одной базы перенести документ в другую базу?
// Выгрузить в файл xml.
ЗаписьXML=Новый ЗаписьXML();
ЗаписьXML.ОткрытьФайл(«c:\doc.xml»);
ЗаписьXML.ЗаписатьНачалоЭлемента(«Root»);

// Получить объект по ссылке.
ВыгружаемыйОбъект=Документ.ПолучитьОбъект();

// С помощью средств сериализации записать объект в файл.
ЗаписатьXML(ЗаписьXML,ВыгружаемыйОбъект);

ЧтениеXML=Новый ЧтениеXML();
ЧтениеXML.ОткрытьФайл(«c:\doc.xml»);

// Текущим становится элемент Root.
ЧтениеXML.Прочитать();

// Текущим становится элемент с документом.
ЧтениеXML.Прочитать();

// Проверить сможет ли с данным значением «справиться»
// система сериализации в данной базе.
Если ВозможностьЧтенияXML(ЧтениеXML) Тогда

// Получить ДокументОбъект.РеализацияТоваровУслуг
ЗагружаемыйОбъект=ПрочитатьXML(ЧтениеXML);

ЧтениеXML.Закрыть();
Как можно сформировать XML-документ произвольной структуры?
Запись = Новый ЗаписьXML;
Запись.ОткрытьФайл(ПутьКФайлу);
Запись.ЗаписатьОбъявлениеXML();
Запись.ЗаписатьНачалоЭлемента(«Корневой»);
Запись.ЗаписатьАтрибут(«Справочник», «Номенклатура»);
Запись.ЗаписатьКомментарий(«Краткая информация о номенклатуре»);

Пока Выборка.Следующий() Цикл
Если Выборка.ЭтоГруппа Тогда
Продолжить;
КонецЕсли;

Запись.ЗаписатьНачалоЭлемента(«Элемент»);
Запись.ЗаписатьАтрибут(«Код», Строка(Выборка.Код));
Запись.ЗаписатьАтрибут(«Артикул», Строка(Выборка.Артикул));
Запись.ЗаписатьТекст(Выборка.Наименование);
Запись.ЗаписатьКонецЭлемента();
КонецЦикла;

Запись.ЗаписатьКонецЭлемента();
Запись.Закрыть();
Как сформировать XML-документ в строку?
Запись = Новый ЗаписьXML();
Запись.УстановитьСтроку();
Запись.ЗаписатьОбъявлениеXML();
Запись.ЗаписатьНачалоЭлемента(«Корневой»);
Запись.ЗаписатьАтрибут(«Справочник», «Номенклатура»);
Запись.ЗаписатьКомментарий(«Краткая информация о номенклатуре»);

Пока Выборка.Следующий() Цикл
Если Выборка.ЭтоГруппа Тогда
Продолжить;
КонецЕсли;

Запись.ЗаписатьНачалоЭлемента(«Элемент»);
Запись.ЗаписатьАтрибут(«Код», Строка(Выборка.Код));
Запись.ЗаписатьАтрибут(«Артикул», Строка(Выборка.Артикул));
Запись.ЗаписатьТекст(Выборка.Наименование);
Запись.ЗаписатьКонецЭлемента();
КонецЦикла;

Запись.ЗаписатьКонецЭлемента();
Стр = Запись.Закрыть();
Сообщить(Стр);
Как можно обмениваться данными, используя XML-сериализацию через файлы других форматов?
ЗаписьXML = Новый ЗаписьXML();
ЗаписьXML.УстановитьСтроку();
Данные = СсылкаНаДокумент.ПолучитьОбъект();
ЗаписатьXML(ЗаписьXML, Данные);
ТекстСообщения = ЗаписьXML.Закрыть();

Текст = Новый ТекстовыйДокумент;
Текст.УстановитьТекст(ТекстСообщения);
Текст.Записать(ПутьКФайлу);

Текст = Новый ТекстовыйДокумент;
Текст.Прочитать(ПутьКФайлу);

ЧтениеXML = Новый ЧтениеXML();
ЧтениеXML.УстановитьСтроку(Текст.ПолучитьТекст());

Если ВозможностьЧтенияXML(ЧтениеXML) Тогда
Данные = ПрочитатьXML(ЧтениеXML);
Данные.Записать();
КонецЕсли;
Как можно загрузить XML документ произвольной структуры?
Чтение = Новый ЧтениеXML;
Чтение.ОткрытьФайл(ПутьКФайлу);

Пока Чтение.Прочитать() Цикл

// Прочитать «структурные части» элементов.
// Проверить, какая часть элемента — текущая.
Если Чтение.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
ИмяУзла = Чтение.Имя; Сообщить(«—» + ИмяУзла);

// Атрибуты элементов можно читать только если текущая часть —
// начало элемента
Пока Чтение.ПрочитатьАтрибут() Цикл

// Прочитать данные узла атрибута.
ТипУзла = Чтение.ТипУзла;
Имя = Чтение.Имя;
Значение = Чтение.Значение;

// Обработать полученные значения.

ИначеЕсли Чтение.ТипУзла = ТипУзлаXML.Текст Тогда

// В примере просто выводим текст в окно сообщений.
Сообщить(«Текст:» + Чтение.Значение);

ИначеЕсли Чтение.ТипУзла = ТипУзлаXML.КонецЭлемента Тогда

// В примере просто выводим признак конца элемента
// в окно сообщений Сообщить(«—Конец:» + Чтение.Имя);

Очень нужно для сдачи алкогольной декларации в СКБ-Контур. Может кто-то знает?

Как сохранить документ в формате XML:

  1. Выберите в меню "Файл" пункт "Сохранить как".
  2. В окне "Сохранение файла" выберите в раскрывающемся списке "Тип файла" пункт "XML-документ".

И все, нажимайте "Сохранить"!

Для преобразования файла в Exel в формат XML не требуется никакого дополнительного программного обеспечения.

Microsoft Excel предоставляет два формата файлов для XML. Один из них подходит только для версий Microsoft Excel 2002 и более ранних, другой формат понимается всеми более поздними версиями.

  1. Переходим в меню Файл в Microsoft Excel/ Сохранить как. Важно: обычная команда "сохранить" не предоставляет функциональные возможности конвертирования документов в другие форматы. А "сохранить как" обеспечит необходимое преобразование для документа экспортируемого в XML.
  2. Выберите "XML-данные" под "сохранить как" в раскрывающемся списке меню в нижней части диалогового окна. Это формат XML для всех версий Excel после 2002. Если файл XML будет использоваться более старыми программами Excel, выберите тип файла электронной таблицы XML.

Введите желаемое имя файла для нового файла XML в поле "File Name". Укажите место в поле "Сохранить в".

Нажмите на кнопку "Сохранить". Файл Microsoft Excel будет экспортирован в виде файла XML.

Другие статьи:

Похожие статьи:

Популярное на сайте:

Leave a Reply